PDA

View Full Version : Always use this program to open these files, is grayed out


GGlynnD
12-03-2006, 07:52 PM
Win XP, SP2 When I double click on a file, it will usually open with the correct program, occasionally, an "Open With" window will open up with the list of programs for me to choose one. I will choose the program and then would like for it to ALWAYS open with that program, BUT, the "Always use this program to open these files", is grayed out, in fact in the past year, it has never, not been grayed out. How can I get that option back?
Thanks, gglynnd

sharber60
12-03-2006, 08:17 PM
Would this help in Control panel Folder Options, check the view open & see if
your program is listed there or the association?

Rhett
12-03-2006, 09:19 PM
Does this apply to all file types? Or only certain file types? Should it be the latter, which file types?

GGlynnD
12-03-2006, 09:28 PM
Yes, it is listed there, and it states "opens with WMP". But, when I double click on the file that I want to open with WMP, it does NOT open with WMP, I get the "Open With" window. I can then go down the list and choose WMP, and then I would like to check the box beside "Always use the selected program to open this kind of file", but it is grayed out. After choosing WMP, I can click OK, and it will then open with WMP. As I said, it doesn't make any difference which program I choose to open an appropriate file, I never get the option to check the "Box" for "Always use the selected program to open this kind of file". I remains grayed out. Thank for a quick reply...gglynnd

GGlynnD
12-03-2006, 09:39 PM
Rhett, Most of the files open with the programs they are supposed to. It is a few various files that will not open, and I get the "Open With" window, I can the choose the "right" program for the file and it will open, but, the "Always use the selected program to open this kind of file" remains grayed out. Thanks......gglynnd

GGlynnD
12-04-2006, 03:08 PM
Hello all, I went to google and entered the problem again, this time I got a MS site, http://support.microsoft.com/kb/555076#top . I went there and thought I had solved my problem. Here are the directions I followed:
RESOLUTION
1. Go to "Start" -> "Run" >regedit : Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\policies\Explorer , In the right side of the screen double click on "NoFileAssociate".

Change the value of "NoFileAssociate" from 1 to 0

The problem now is, on the right side of the screen, there was NO “No File Associate” listed.
What now??
gglynnd

HARLEY
12-04-2006, 04:04 PM
Hello all, I went to google and entered the problem again, this time I got a MS site,

Don't start messing with the registry!

Windows has always been a little backwards when it comes to other options for opening files!

I use this program and recommend it highly.....very easy to setup!

OPEN EXPERT (http://www.baxbex.com/openexpert.html)
Just right click any file and choose >Open with>configure Openexpert to open with whatever application you want!

lostkiwi
12-04-2006, 06:04 PM
Here are the steps from when this happened to me, I hope it helps.

http://forum.worldstart.com/showpost.php?p=949340&postcount=10

GGlynnD
12-06-2006, 01:55 AM
Thanks all, I think I will follow Harley's advice, my palms get sweaty when I am in the registry.I will get Open Expert. I really wanted to know what caused it to be grayed out, and now I know.
Lostkiwi, thanks for your technical advice, if I find someone who really knows what they are doing, I may get them to insert " Nofileassociate"....thanks again..gglynnd

lostkiwi
12-08-2006, 02:40 AM
You're welcome and good luck! :)